- 29
- 0
头一次使用docker 找了一个镜像docker.io/skiychan/nginx-php7 打算部署容器。
于是开始执行:
sudo docker run --name nginx -p 8080:80 -d skiychan/nginx-php7
提示内容如下
ARN[0025] Failed to allocate and map port 8080-8080: exec: "docker-proxy": executable file not found in $PATH
ERRO[0026] Handler for POST /v1.26/containers/nginx/start returned error: driver failed programming external connectivity on endpoint nginx (ea9b65d1a1a18b7b1c1869141a9005c5bf71501edea5b5c27ba37f4047147d7c): exec: "docker-proxy": executable file not found in $PATH
Error response from daemon: driver failed programming external connectivity on endpoint nginx (ea9b65d1a1a18b7b1c1869141a9005c5bf71501edea5b5c27ba37f4047147d7c): exec: "docker-proxy": executable file not found in $PATH
Error: failed to start containers: nginx
看提示是缺少docker-prxoy这个可执行文件,而且端口分配失败,容器也启动失败。
但我每次执行 docker start nginx 的时候却输出:
WARN[0031] Failed to allocate and map port 8080-8080: Bind for 0.0.0.0:8080 failed: port is already allocated
ERRO[0031] Handler for POST /v1.26/containers/nginx/start returned error: driver failed programming external connectivity on endpoint nginx (5c4718d32721fe466a9b400216913898eb8b7909f1ce73188e8db360cb55ff19): Bind for 0.0.0.0:8080 failed: port is already allocated
Error response from daemon: driver failed programming external connectivity on endpoint nginx (5c4718d32721fe466a9b400216913898eb8b7909f1ce73188e8db360cb55ff19): Bind for 0.0.0.0:8080 failed: port is already allocated
Error: failed to start containers: nginx
看样子端口已经分配了,但容器还是启动失败的样子。
求解如何使用docker,docker是yum安装在centos上的 版本号为:1.13.1。
- 共 0 条
- 全部回答
-
云顶红尘客 普通会员 1楼
The error message "exec: "docker-proxy": executable file not found in $PATH" is indicating that the
docker-proxyexecutable file is not in the system's PATH environment variable.To resolve this issue, you can add the
docker-proxyexecutable to your PATH by running the following command:bash export PATH=$PATH:/usr/local/bin/docker-proxyMake sure to replace
/usr/local/bin/docker-proxywith the actual path to the Docker-proxy executable on your system.Alternatively, you can specify the full path to the Docker-proxy executable in your Dockerfile or command:
bash COPY my-proxy /usr/local/bin/docker-proxyThis will make sure that the
docker-proxyexecutable is always available in your system's PATH, regardless of where it was installed.
- 扫一扫访问手机版
回答动态

- 神奇的四哥:发布了悬赏问题阿里云幻兽帕鲁服务器更新之后。服务器里面有部分玩家要重新创建角色是怎么回事啊?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题函数计算不同地域的是不能用内网吧?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题ARMS可以创建多个应用嘛?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题在ARMS如何申请加入公测呀?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题前端小程序接入这个arms具体是如何接入监控的,这个init方法在哪里进行添加?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题阿里云幻兽帕鲁服务器刚到期,是不是就不能再导出存档了呢?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题阿里云幻兽帕鲁服务器的游戏版本不兼容 尝试更新怎么解决?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题阿里云幻兽帕鲁服务器服务器升级以后 就链接不上了,怎么办?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题阿里云幻兽帕鲁服务器转移以后服务器进不去了,怎么解决?预计能赚取 0积分收益

- 神奇的四哥:发布了悬赏问题阿里云幻兽帕鲁服务器修改参数后游戏进入不了,是什么情况?预计能赚取 0积分收益
- 回到顶部
- 回到顶部

