账号密码登录
微信安全登录
微信扫描二维码登录

登录后绑定QQ、微信即可实现信息互通

手机验证码登录
找回密码返回
邮箱找回 手机找回
注册账号返回
其他登录方式
分享
  • 收藏
    X
    tomcat重启后,web页面无法显示!
    79
    0

    利用tomcat的startup.sh 与 shutdown.sh 重启tomcat.
    重启是因为要在webapps放入新的文件.
    步骤是:
    先shutdown, 后放入webapps文件,后startup启动,
    第一次startup没有报错

    [root@iz2zea0v6yzqrn1lbze76iz ~]# sh tom.sh 1
    Using CATALINA_BASE:   /usr/local/tomcat/tomcat907_1
    Using CATALINA_HOME:   /usr/local/tomcat/tomcat907_1
    Using CATALINA_TMPDIR: /usr/local/tomcat/tomcat907_1/temp
    Using JRE_HOME:        /usr/local/java/jdk9
    Using CLASSPATH:       /usr/local/tomcat/tomcat907_1/bin/bootstrap.jar:/usr/local/tomcat/tomcat907_1/bin/tomcat-juli.jar
    **Tomcat started.**
    tom.sh run succeed. 

    shutdown了下,也没有报错.

    [root@iz2zea0v6yzqrn1lbze76iz ~]# sh tom.sh 0
    Using CATALINA_BASE:   /usr/local/tomcat/tomcat907_1
    Using CATALINA_HOME:   /usr/local/tomcat/tomcat907_1
    Using CATALINA_TMPDIR: /usr/local/tomcat/tomcat907_1/temp
    Using JRE_HOME:        /usr/local/java/jdk9
    Using CLASSPATH:       /usr/local/tomcat/tomcat907_1/bin/bootstrap.jar:/usr/local/tomcat/tomcat907_1/bin/tomcat-juli.jar
    NOTE: Picked up JDK_JAVA_OPTIONS:  --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED
    tom.sh run succeed.

    但最后问题就来了,之后更改了webapps文件,其后要再启动,
    启动是像之前一样没有报错的,但是我继而访问网页
    无法访问此网站
    www.ykmimi.com 拒绝了我们的连接请求。


    其后我想再重启一下,关闭tomcat,遇到bug报错:

    [root@iz2zea0v6yzqrn1lbze76iz ~]# sh tom.sh 0
    Using CATALINA_BASE:   /usr/local/tomcat/tomcat907_1
    Using CATALINA_HOME:   /usr/local/tomcat/tomcat907_1
    Using CATALINA_TMPDIR: /usr/local/tomcat/tomcat907_1/temp
    Using JRE_HOME:        /usr/local/java/jdk9
    Using CLASSPATH:       /usr/local/tomcat/tomcat907_1/bin/bootstrap.jar:/usr/local/tomcat/tomcat907_1/bin/tomcat-juli.jar
    NOTE: Picked up JDK_JAVA_OPTIONS:  --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED
    May 07, 2018 8:03:27 PM org.apache.catalina.startup.Catalina stopServer
    SEVERE: Could not contact [localhost:[8005]]. Tomcat may not be running.
    May 07, 2018 8:03:27 PM org.apache.catalina.startup.Catalina stopServer
    SEVERE: Catalina.stop: 
    java.net.ConnectException: Connection refused (Connection refused)
        at java.base/java.net.PlainSocketImpl.socketConnect(Native Method)
        at java.base/java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:400)
        at java.base/java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:243)
        at java.base/java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:225)
        at java.base/java.net.SocksSocketImpl.connect(SocksSocketImpl.java:402)
        at java.base/java.net.Socket.connect(Socket.java:591)
        at java.base/java.net.Socket.connect(Socket.java:540)
        at java.base/java.net.Socket.<init>(Socket.java:436)
        at java.base/java.net.Socket.<init>(Socket.java:213)
        at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:498)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:564)
        at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:403)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:494)
    
    tom.sh run succeed. 
    

    补充:云服务器重启了,进行上述步骤,问题依旧?

    0
    打赏
    收藏
    点击回答
        全部回答
    • 共 0 条
    • 麻货 普通会员 1楼

      Tomcat重启后,web页面无法显示可能有以下几个原因:

      1. 服务器配置错误:检查Tomcat服务器的配置文件,确保服务器正在运行,并且所有必要的环境变量和库已经正确配置。

      2. 网络问题:检查网络连接,确认Tomcat服务器的端口是否已经开放,并且可以正常访问。

      3. Tomcat缓存问题:Tomcat缓存可能会影响Web页面的显示。您可以尝试清理Tomcat缓存,或者将Web页面的路径设置为较短的路径。

      4. web.xml文件问题:如果web.xml文件中有问题,那么在重启Tomcat后,这些问题可能仍然存在。您可以尝试删除或修改web.xml文件,然后重新启动Tomcat。

      5. 系统资源问题:如果Tomcat运行过程中占用的系统资源过多,那么可能会影响Web页面的显示。您可以尝试增加Tomcat的运行时内存,或者关闭不必要的后台进程。

      如果以上方法都无法解决问题,那么可能需要联系Tomcat的管理员或者专业的技术支持。

    更多回答
    扫一扫访问手机版
    • 回到顶部
    • 回到顶部